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Stress-Strain Data with EXCEL 
 Welcome to the Mechanical Testing Instructional Lab (MTIL). 
 The gears can be a little rusty at the start of a new semester and new material can be a 
bit unnerving. The processing of data from MTIL experiments may be the first time that 
you have analyzed large sets of real data. This narrative will help you get started on the lab 
reports by providing step-by-step instructions for converting an Instron data file to a stress-
strain curve. Additionally, a list of helpful EXCEL commands is included to make data 
reduction and report assembly more efficient. By no means does this information tell you 
everything you’ll need to know, but provides assistance in constructing a curve you will 
get to know very well during the semester. You will also discover a plethora of extra tricks 
in WORD and EXCEL as the semester progresses, so take advantage of the group setting 
to learn from your classmates! 

The Tensile Test 
 This example uses data recorded during tensile testing on an Instron testing machine. 
The specimen is made of 6150 Steel. During the test, the load increases to a maximum 
value, then decreases. Eventually the specimen breaks. 
 Information about the specimen and testing conditions are recorded in a header file. 
Data are recorded during the test. We are primarily interested in the tensile load and the 
corresponding relative change in length, linear strain. The data are used to generate a 
stress-strain curve. 
Download the Data 
 Get started by retrieving data files from the server at: 

http://mtil.illinois.edu/DATA 

 The raw test data are accessed in your class directory (or /MTIL666) in 
00-TensileExample. Display the file in a browser, then right-click to “Save Page as …”. 
Files generated during testing are in ASCII tab-delimited format and have the extension 
.txt. The stem, “EXC6150”, is entered at the time of testing. The header file, designated by 
_h.txt, lists test parameters such as the specimen diameter and the crosshead rate. The data 
file, designated by _d.txt, contains the data for load and strain as well as crosshead 
displacement and time. Download both test files to your hard drive. They will available to 
start over in case of an error. For convenience, put all files in a folder (directory) such as 
“My Tensile Example”. 
About Using EXCEL 
 The following procedure is not the only way to process data. Part of the “philosophy” 
here is that all data from a test are placed on a single worksheet and processed. Other 
worksheets may be used for different tests. Specific techniques may vary for different 
versions of EXCEL. 
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 Assistance is available by selecting Help on the menu bar. For more complete 
descriptions of engineering applications in EXCEL, see the references at the end. When 
using search engines, begin the entry with “EXCEL”, your platform and version. 
New workbook 
 Open a blank workbook. Go to Sheet1. (See the tabs at bottom of the window). Be sure 
that the formula bar is displayed at the top of the screen. The formula bar has the cell 
address in the Name Box and its contents. (View>Formula Bar) 

 

 
 In cell A1, type a title – “Tensile Example”, press Enter. In A2, “6150 Steel”. A title 
can help to locate a reference quickly when you are working with data from many tests. 
Move to the title in the bottom tab, “Sheet1”. Double click or right-click to rename the 
Worksheet as “6150Example”. In future assignments, you may want to analyze each 
material (or test) on a separate worksheet. 
 Save your file. Helpful hint: Save your data periodically to a new filename. Keep the 
same basic stem, but progressively number as Steel6150Tens#1.xls, Steel6150Tens#2.xls, 
etc. If a major error is made, you can step back to a “good” saved version.  
Enter the header data. 
 Highlight a cell in column A, a few rows down from the title. [Mouse over to the cell 
and click or move with the down arrow ()]. (In the example, the cell is A4.) Go to your 
data directory and open the EXC6150_h.txt header file that you downloaded. Select ALL, 
and then Copy. Go back to EXCEL and paste these data into the worksheet. Increase the 
width of column A to see full descriptions. (Double click on the border between the 
column headers, “A” and “B”. Column A will expand to display the widest entry in the 
column.) 
Enter the test data. 
 On your worksheet in column A, highlight a cell that is a few rows down from the last 
line of the header file (A30 in the example). In your data directory, open the 
EXC6150_d.txt file, select ALL, copy, and paste into the worksheet. NOTE: the * is an 
indicator for some programs that the next row is a header row. 
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A Note on Importing Data 
 The files generated in the lab are tab-limited so that they easily paste into the 
worksheets. Importing data using Data>Get External Data> is not required. 
You should have something similar to: 

 
 The EXCEL workbook Steel6150Tens.xls containing a completed example is located 
in the HELP folder. 

Formulas and References – Relative and Absolute 
 Formulas start with “=”. Remember that when a formula is copied, the cell addresses 
change. This is one of the most powerful features of spreadsheet programs. When the 
formula in C32, “=A32 * B32”, is copied to cell C33, it becomes “=A33 * B33”, and so on 
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down the column. The value in column C is the product of the values in columns A and B 
in the same row. This task is an example of a relative reference; wherever the cell is 
copied, the result is the product of the values in the two cells to the left of it.  
 Often, an operation is performed on many cells with a constant value. To compute 
engineering stress, the load in each row is divided by the original cross-sectional area. One 
method (not recommended) is to type the calculated area in the formula. It is a better 
technique to use the address of the cell that contains the area data. To make a reference 
absolute (constant), place “$” in front of the column and row. For the example above, 
“=$A$32 * B32” copied to C33 results in “=$A$32 * B33”. This feature may be used 
efficiently in our example. First compute the cross-sectional area and make the cell address 
a constant divisor in the formulas employing the “$” designations. 
 Another way to specify a constant is to name the cell. This is especially convenient 
when many different data sets are being analyzed. In the current sheet, locate “Specimen 
diameter:” in Column A (A12). Highlight the adjacent cell in column B (B12). From the 
menu bar (top of screen), choose Insert>Name>Define. Excel may suggest a name based 
on column A. Since there may be more than one 6150 steel specimen, call this one 
“Stl6150a” and add “diameter”. 

 
 Name: Stl6150a_diameter (highlighted); cell address = B12 in the current Sheet 
(bottom of the Define Name frame.) (Note: Names are not case sensitive.) Click OK. Note 
that the Name Box on the formula bar now displays the name rather than the column and 
row. 
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 Accessing the Define Name window is the only way to delete names and edit their 
ranges. 

 Names may also be entered on the Formula Bar. The final diameter is displayed in cell 
B26. The formula bar displays the cell address in the Name Box and contents. 

 
 Type the desired name in the Name Box and press Return. 

 
 An entire range of cells may be highlighted and assigned a name in this manner. 
Names and their ranges may not be edited using this technique. 
NOTE: Names must start with a letter or underscore, but may not be the same as a possible 
cell address. The most recent versions of EXCEL designate cell addresses using up to 3 
letters and 7 digits, e.g., abc1023456. Therefore, “Stl6150” and “Al2024” are invalid 
names. Some valid alternatives are “Stl6150a”, “_Stl6150”, “Steel6150”, “Stl_6150”, and 
“Al_2024”. 

Pi 
 The constant, pi, is PI(). Note the empty parenthesis. A good technique is to enter 
functions in lower case. If the formula is correct, EXCEL converts it to caps. If not, it 
remains in lower case indicating an error. 

Area 
 Arrow right () to cell D12 and type in “Area:”. Set this label to align right with 
Format>Cells>Alignment, Horizontal: Right. In column E enter the formula for area, 
πd2/4. Start the formula with “= pi() *”. To enter the diameter, click on the cell you just 
named (Stl6150a_diameter). Square with “^2”, then divide by 4 (“/4”). The result is: 

= PI() * Stl6150a_diameter^2 /4 
 Name this cell (E12) “Stl6150a_area”. 

 Type the units “mm^2” in column F. 
The use of names may appear to be trivial here. When large amounts of data are 
compiled, names can be very useful. For example, data, including diameter, from 
15 tests could be summarized in a table on the 17th spreadsheet of the workbook. 
For the test 6150a, simply enter the formula “=6150a_diameter”. The process may 
be streamlined with database functions, so that the diameter for each test will 
(nearly) automatically be reported in the table. 
Your completed worksheet can be copied as a new worksheet, and then data from 
another test can be pasted. Since the data formats are the same, the new 
diameter is in the right place and the corresponding area and other formulas are 
immediately recalculated. 

 Now stresses can be calculated. Find the label “Time (sec)” in column D. On the same 
row, in column E (E31), enter “Stress (MPa)”. 
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Definition of units of Stress 
1 Pa = N/m2 

Or,  

� 

Stress (Pa ) =
Load (N )
Area (m 2 )  

1 MPa = 106 Pa 
1 mm = 10-3 m 
1 mm2 = 10-6 m2 
1/ mm2 = 106 /m2 

 Therefore, 

� 

Stress (MPa ) =
Load (N )
Area (mm 2 )  

 Note that the test load (column B) data are recorded in units of kN (1000N). Therefore, 

� 

Stress (MPa ) =
Load (kN )
Area (mm 2 ) * 1000  

 
Enter the formula (Stress =……) 
 In the Stress column (E), highlight the cell below “Stress(MPa)” (E32). Start the 
formula with “=”. In the same row, click on the load value (B32). Then type “* 1000 /”. 
Click on the cell with the area (Stl6150a_area). For the cell E32, the formula is: 

= B32 *1000 / Stl6150a_area 
Stl6150a_area is an absolute reference (constant). The load (Column B) is a variable. 
Copy the formula to derive stress from the load data 
 Copy the formula in E32 down the column to the last row of data. 
 One way to copy the formula down the column is to highlight the cell to be copied 
(E32), and then move the cursor to the bottom-right corner of the cell. Note that a “+” sign 
appears. You may copy the formula by dragging this corner down the column. That is a 
long drag! There must be a better way! 
 When the “+” sign appears, double click on it. The column will be filled until an empty 
cell in column B is encountered. Scroll down the column with the down arrow (). Note 
the display of the formula for different cells in the formula bar. 

 Save your work. 
Plotting the Data 
 There are a lot of numbers organized in columns. “A picture is worth a thousand 
words” or a whole table of numbers! 

 Next, we will create a graphical image of the data. In EXCEL, plots (graphs) are called 
Charts. (Perhaps, because the spreadsheet is rooted in accounting?!) Select the two 
columns of data. Click on the letter at the top (column label) of the strain column to 
highlight the entire column (C). Press and hold control [command () for Mac], then click 
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the top of the stress column (on the “E”). Both columns are selected and highlighted. 
(Column D is not selected.) Depending on the version, click on the Gallery icon, then 

Charts or select Chart Wizard on the toolbar. Choose ‘XY (Scatter)’, then select 
points only. [NOTE: Line charts are designed for equally spaced data. Do NOT use 
here!!!]. The details of your display may be different from this presentation. 

Note:  In general, use only points with no lines for 
experimental data and lines with no points for 
correlations and theoretical constructions. 
 If you get only a plot, right-click on the chart 
and then Select Data. 
 Click Next> if available. 

 The Range contains ALL of the charting 
(plotting) data. Series contain data for individual 
plots. For this test, the “Series in:” choice is 
Columns. 

 The initial selection was all of column C and all of column E, so the range starts at 
row 1. Useful data start at row 32. 

 In the Data Range box, change the $1 references to $32 for both C and E to get: 
='6150Tens'!$C$32:$C$404,'6150Tens'!$E$32:$E$404 

 The X and Y scale ranges will adjust automatically. 

 Click Next> if available. 
 Enter title (Steel 6150 – Stress-Strain) and axis labels (Strain and Stress (MPa)). Note 
that a preview appears in the window. 
 Press Next>. 

 Have the chart appear in the same worksheet. Press Finish>, then Save the workbook. 
 On recent versions, changes are performed using the Formatting Palette. If the palette 
is not visible, select View on the top menu bar, then Formatting Palette. Chart Options and 
Chart Data are the most useful. 

 It’s okay, but it needs work. Save! 
Extraneous Data 
 There is a point around Strain = 0.08, Stress = 0 that does not belong to the test. 
Between the time that the test computer requested data from the testing machine and the 
time the machine reported data, the specimen failed. This point is not part of the test and 
must be eliminated. 
 Eliminate the point by the deleting the data in the cells on row 404 or delete the entire 
row. To find the last row, click on a cell within the recorded stress-strain data, and then 
press End, then arrow down (). The last data entry in the column is highlighted. Delete 
the data or the entire last row. Ascertain that the point has vanished from the graph. 
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Improving Appearance 
 A good plot helps you understand the data and is a major tool communicating your 
message in a report. The emphasis is on clarity rather than artistry. Use only one or two 
fonts. Avoid wild color schemes. 

 Improve the readability of the Y-axis by using the Number format with no decimal 
points. The graph should be positive for all data. To adjust the axes, right-click on any 
number label to pop up “Format Axis.” Set the Scale for a minimum value of 0. Adjust the 
maximum if necessary. For “Number”, select “Number” (rather than “Scientific”) and 
decimal places = 0. UNcheck “Linked to Source.” 
 The X-axis may be displayed as recorded in non-dimensional units. Right-click a 
number label. Set the minimum to 0. 
 Usually, strain is reported in percent (as on the Instron display). Set the number format 
for the X-axis as Percent with decimal places = 0. 
 The menu bar Chart or the Formatting Palette allows entry of Titles for the chart and 
axes under Chart Options. 
 For this plot of one set of data, there is no need for the legend. Select the chart 
(changes to a darkened border). The “Chart” option appears on the EXCEL menu (top), 
select Chart>Options>Legend. (Alternatively, right-click in the chart area.) Select 
“Legend” and UNcheck Legend. On the Formatting Palette, use Chart Options. 
 We have chosen to display discrete points rather than points joined by lines. Large 
markers tend to obfuscate the details of the experiment. Right-click on the plotted data 
points to “Format Data Series”. (This selection is distinguished from “Format Data 
Point”). The “No Line” Option should already be chosen. DEselect “Shadow”. Choose a 
point shape and make the point size as small as possible. 

 After the plot is complete, most options may be accessed with a right-click on the 
graph. Or use the Chart menu at the top of the screen. The Chart Formatting Palette may be 
displayed by clicking on Toolbox or by using the View option. 
 Save your work. 

 Experiment with the various chart options: Colors (Foreground and Background) for 
Series and the chart itself, Grid lines, Tick marks, Number formats, Fonts, Scales, Markers, 
Stretch the size (internal grid and entire chart window), etc. Create the good, the bad and 
the ugly! 

 Try this. Left-click on the last data point of the series. “Format Data Point” will pop up. 
Choose “Show Label”. On the chart, highlight the displayed label, and type in “X” to 
indicate fracture. Under Format Data Labels, set all alignments to “Center.” Adjust the size 
to make it obvious. Alternatively, format the point with an “X” shaped marker. 

 A few items to notice on the curve: important engineering features include (a) the 
linear elastic region, (b) the yield point, (c) the ultimate tensile strength (UTS), and (d) the 
failure point. 
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About Reports 
 Remember that table headings go above the table and figure captions go below the 
figure. 
 Always make sure that when multiple curves are on the same figure, the lines/symbols 
are independent of color. The report might be printed or copied on a non-color device, so 
the figures need to be explicable even in black and white. 

Hints – Learned during the course 
Some EXCEL tips: 

• Ctrl + Home takes you back to cell A1. 

• Arguments of a function must be enclosed in parentheses [e.g., ln 10 is =ln(10)]. 

• Trigonometric functions use radians as their argument! 

• DEGREES(angle) converts radians to degrees and RADIANS(angle) converts 
degrees to radians. 

• Pressing End then an arrow key navigates along a column or row [depending on 
which arrow key you use]. Starting in an empty cell, the first occupied cell is 
found. Starting within a series of occupied cells, the last occupied cell is located. 

• Holding the Ctrl key while selecting cells with the mouse allows you to select 
individual cells anywhere in the worksheet. 

• Holding the Shift key while arrowing in any direction selects cells like dragging the 
mouse—this also conveniently allows you to deselect cells, for instance if you 
accidentally selected one too many cells in a long column of data. 

• Alt + Shift + F1 inserts a new worksheet. 

• From the menus select Insert>Comment to add a comment to a cell.  This helps 
your worksheet organization and allows any user to understand the purpose of the 
cell. 

• Window>Freeze Panes is used to keep column or row headers stationary while the 
data are scrolled. 

• “New Window” opens a new frame to navigate separately in the worksheet. You 
can be in two places at once! Remember that a change in one window affects both 
views. 

• The function icon opens the formula toolbar to see all built-in functions. 

• Referencing cells in a different sheet: to reference cell D7 in Sheet 2 from another 
sheet use =Sheet2!D7. Or use its name! 

• A “circular reference” warning means you referenced a cell to itself. Use the trace 
tool to analyze. 

• Right click on a cell to add comments to document your procedures. 
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